
RESOURCES
	n indesignsecrets.com is now part of CreativePro

	n creativepro.com

	n InDesign Magazine (creativepro.com/magazine)

	n YouTube: https://www.youtube.com/creativepro

	n linkedin.com/learning  
(including many free videos in the InDesign Secrets title)

Bio: David Blatner is the author of 15 books and 
dozens of videos about InDesign, Photoshop, 
and many other topics—including the mysteries 
of pi (π), science, and religion. He’s the co-host 
of InDesignSecrets.com, CreativePro.com, 
and the CreativePro Week conference; the 
founder and publisher of CreativePro Magazine 
and InDesign Magazine; and the presenter 
of “InDesign Essential Training” at LinkedIn 
Learning.

Books: Check out our collection of books at 
CreativePro.com/shop (or get our “Top Tips for 
InDesign” ebook free with a membership!)

WHILE THIS PDF IS JUST FOR YOU, HERE’S  
A GREAT DISCOUNT TO SHARE WITH YOUR  
FRIENDS: $10 OFF A 1-YEAR PREMIUM MEMBERSHIPTop Tips
     for InDesign
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DOWNLOAD YOUR FREE 
CREATIVEPRO STARTER KIT TODAY!

Download now at CreativePro.com/Starter-kit

Get a taste of the valuable  
resources that are included in  

CreativePro membership:

Includes: Free Top Tips ebooks 
for InDesign, Illustrator, and 

Photoshop!
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INDESIGN FUNDAMENTALS
Learning a few keyboardshortcuts is so important for effi-
ciency in InDesign! Check out the keyboard shortcuts chart 
later in this PDF… pick out one new shortcut to learn each day 
for 10 day! Keep practicing them until they become second 
nature.

Let InDesign do the Math For You

You can do math in every field that takes a number. So, for 
example, you can make a frame half as wide by typing “/2” 
after the number.

http://creativepro.com/indesign-does-math-for-you

Take Time Now to  
Save More Time in the Future!

1.  Edit Your Keyboard Shortcuts

Take time now to save time downstream! Use Edit > 
Keyboard Shortcuts (or Keyboard Shortcuts panel from 

Blatner Tools). For example, edit Panel menus: Fraction, or 
Insert most recent glyph.

2.  Customize Panels and Save in Custom Workspaces

Set up your panels the way you want them (including Links 
panel options dialog box, Mini Bridge panel setup, Control 
panel customization, etc.) and then save everything in your 
own workspace! Remember that when you return to a work-
space, it remembers how you left it; choose Reset to bring it 
back to its clean state.

3.  Preferences You Should Change

Examples of preferences you may want to change, are: 
Leading; Greek text; maybe vector graphics; Keyboard incre-
ments; Story Editor; Find Missing Links; Ink Manager: Use Lab 
Values

Document preferences apply to currently open document. 
Application prefs apply to all future documents (and some-
times to previous docs).

Also, remember that you can add/remove “default” colors 
swatches & styles, re-order color swatches while no docu-
ments are open.
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Managing Styles

1.  How to Strip Out Text Formatting You Don’t Want

You can remove all local formatting by selecting all (Cmd/
Ctrl-A) and clicking the Clear Overides button in the Paragraph 
Styles dialog box. But to keep some formatting, make and 
apply character styles first.

2.  Watch Out for Default Formatting

Anything you choose (character style, paragraph style, color 
swatch, etc.) when nothing is selected on the page becomes 
the new default. This can be powerful or dangerous.

Use Story Editor

The Story Editor (Edit > Edit in Story Editor, or Cmd/Ctrl-Y 
to sync up current text selection) is your friend! Use it! But 
remember to change the display preferences to make it easier 
to read.

Get Used to Quick Apply

Use Quick Apply (Command-Return/Ctrl-Enter) to apply styles 
quickly. No need to scroll through long lists of styles, no need 
to memorize even more keyboard shortcuts for your styles. 
You can also press Command-Enter twice to edit styles!

Quick Apply is also great for applying menu commands to 
selections (not just text!). If the command is in a menu or is a 
script or variable, you can apply/insert it from Quick Apply.

Find What You Need in the Glyphs Panel

Dock it for quick reference; zoom in to see better; use the 
Show menu to filter your search; click and hold for alternates 
(when indicated). 

Other special characters live in the Type > Insert Special 
Characters submenu (and other submenus).
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Customize the Links Panel

The Links panel is just a starting point! Use Panel options to 
add various metadata (resolution, scaling, color model, etc.), 
then sort by any of these. Remember to save in your custom 
workspace.

Customize to add most-frequently accessed data to top 
half. Save in custom workspace to maintain custom settings. 
Consider embedding links in some documents. Use Copy To 
from the panel menu to gather all linked images into one 
folder.

Intertwined Letters

When you want to make it look like two objects are inter-
twined (part over and part under), select the bottom object 
and copy it, then drag out a new frame over the part where 
you want them to overlap, and then use Edit > Paste Into. 
Easy and fun!

RGB vs CMYK:
	n Why You Should Import RGB Images Into InDesign and 

Convert to CMYK On Export: https://indesignsecrets.
com/import-rgb-images-indesign-convert-cmyk-
export.php

	n RGB Workflow from Photoshop to 
Final PDF: https://creativepro.com/
rgb-workflow-from-photoshop-to-final-pdf/

Converting Text to Outlines

Convert text to outlines the right way: If someone says “con-
vert all your text to outlines,” you should really question them. 
This may be a reasonable request when making signage, or 
promotional products, or other custom print situations. It is 
not reasonable for normal printing! That said, if you’re going 
to do it, do it right. Export PDF as usual and then use Acrobat 
DC: Open the Print Production panel and choose Preflight. In 
the Search field, search for “outline” to select the “Converts 
fonts to outlines” fixup. Click Analyze and Fix and then save 
as… https://creativepro.com/outlining-fonts-the-2016-edition
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SCRIPTS
InDesign is highly extensible through add-ons (plug-ins, 
scripts, extensions).

Managing Scripts

Installing Scripts: The easiest way to install a script is to 
open the Scripts panel (Window > Utilities > Scripts), right 
click on the User folder, and choose Open in Finder/Reveal 
in Explorer. Drat scripts into the Scripts Panel folder (not 
loose in the Scripts panel). 
https://creativepro.com/how-to-install-scripts-in-indesign/

Saving Scripts: If you find a script in a forum or blog post, 
you may need to copy and save it as a .jsx file before you 
install it. Most common mistake: having straight quotes get 
changed to curly/typographer’s quotes! Be sure to use a 
plain text editor so that doesn’t happen. 
https://creativepro.com/how-to-install-a-script-in-
indesign-that-you-found-in-a-forum-or-blog-post/

Organizing your scripts: Scripts appear in the Scripts panel 
in the same structure and order as they appear inside the 
folder in Mac OS/Windows. You can rename them or put 
them in subfolders to organize them. 
https://creativepro.com/tip-organizing-scripts-into-folders/ 
https://creativepro.com/
tip-controlling-order-scripts-panel/

Use QuickApply: You can run a script by double-clicking 
on it in the Scripts panel, or you can use QuickApply (press 
Command-Return or Ctrl-Enter). Enable Scripts inside the 
little menu inside the QuickApply window. After you enable 
scripts here, you can filter the QuickApply results by typing 
s:  
https://creativepro.com/
tip-using-quick-apply-to-run-scripts/

Assigning KBSC: If you use a script very often, it’s worth 
taking the time to use Edit > Keyboard Shortcuts to apply 
a shortcut to it. Choose “Scripts” from the Product Area 
pop-up menu. 
https://creativepro.com/
assigning-keyboard-shortcuts-scripts/
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Sample Scripts:
	n MakeGrid
	n FindChangeByList
	n Learn more about the “sample” scripts that ship with 

InDesign, in the Scripts panel: 
https://creativepro.com/
default-sample-scripts-indesign

More Scripts
	n Layout Zone 
http://www.automatication.com/index.php?id=12

	n CalendarWizard 
http://calendarwizard.sourceforge.net/

	n StorySplitter: Let’s you split text threads before or after 
any text frame. (By Adi Ravid)  
https://creativepro.com/how-to-split-long-story-
into-smaller-pieces-unthreading-middle-story/

	n Insert a Character by Unicode or GID 
https://creativepro.com/
insert-a-character-by-unicode-or-gid/

	n Exchange or Swap Two Images:  
https://creativepro.com/exchange-or-swap-two-
images-free-indesign-script/

	n A Script to Show Options for Placed Files: 
https://creativepro.com/script-show-options-files/

	n Price Adjuster: Lets you do math to numbers inside 
your documents. (By Peter Kahrel; replaces the older 
NumberAdjuster script.)  
https://creativepro.com/files/kahrel/indesign/price_
adjuster.html

	n Table Sort: Sorts selected rows inside a table  
(Peter Kahrel) 
https://creativepro.com/files/kahrel/indesign/
tablesort.html
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Documents
New default document z U N Ctrl+Alt+N

Close all open documents z U X W Ctrl+Shift+Alt+W

Rebuild Preferences (press during 
program launch until Alert appears)

Ctrl z U X Ctrl+Shift+Alt

Document History & Plug-in Info z About InDesign Ctrl+About InDesign

Toggle Measurement System z U X U Ctrl+Shift+Alt+U

Tools panel
Temporary Hand Tool U Spacebar Alt+Spacebar

Temporary Zoom Tool z Spacebar Ctrl+Spacebar

Apply default fill and stroke colors D D

Swap fill and stroke activation X X

Swap fill and stroke colors X X Shift+X

Toggle color affects text/its frame J J

Preview mode on/off W W

Text
Load Find and Find Next instance X F1 Shift+F1

Load Find with selected text z F1 Ctrl+F1

Load Replace with selected text z F2 Ctrl+F2

Replace Change To text and Find Next X F3 Shift+F3

Recompose all stories z U / Ctrl+Alt+/

Toggle Typographer’s Quotes Pref. U X z ’ Ctrl+Shift+Alt+’

Create outlines (text remains) z U X O Ctrl+Shift+Alt+O

Align to baseline grid z U X G Ctrl+Shift+Alt+G

Auto-hyphenate on/off z U X H Ctrl+Shift+Alt+H

Toggle Table Cell/Text Selection Escape Escape

Object editing
Edit Original U doubleclick Alt+doubleclick

Decrease size / scale by 1% 5% z , z U , Ctrl+, Ctrl+Alt+,

Increase size / scale by 1% 5% z . z U . Ctrl+. Ctrl+Alt+.

Nudge by 1/10 z X Arrow Keys Ctrl+Shift+Arrows

Nudge by 10× X Arrow Keys Shift+Arrow Keys

Toggle Live Corners Mode 4 4

Override Master Page item z X click Ctrl+Shift+ click

Select Container, Content esc, Xesc esc, Shift+esc

Transform Sequence Again z U 4 Ctrl+Alt+4

Transform: Move Item z X M Ctrl+Shift+M

Hide z 3 Ctrl+3

Show All On Spread z U 3 Ctrl+Alt+3

Text navigation
Move to the start of the line Home Home

Move to the end of the line End End

Move to beginning of story z Home Ctrl+Home

Move to end of story z End Ctrl+End

Select to end of story z X End Ctrl+Shift+End

Move to the next paragraph z Down Arrow Ctrl+Down Arrow

Move to the previous paragraph z Up Arrow Ctrl+Up Arrow

Go to first frame in thread z U X Page Up Ctrl+Shift+Alt+Pg Up

Go to last frame in thread z U X Page Down Ctrl+Shift+Alt+Pg Dn

Go to next frame in thread z U Page Down Ctrl+Alt+Page Down

Go to previous frame in thread z U Page Up Ctrl+Alt+Page Up

Select current line z X \ Ctrl+Shift+\
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Character formatting
Auto leading z U X A Ctrl+Shift+Alt+A

Increase/Decrease Baseline shift U X Up/Down Arrow Alt+Shift+Up/Down Arr.

Increase/Decrease Baseline shift 5× z U X Up/Down Arrow Ctrl+Shift+Alt+Up/Down

Increase/Decrease Kerning/Tracking U Right/Left Arrow Alt+Right/Left Arrow

Increase/Decrease Kerning/Tracking 
5×

z U Right/Left Arrow Ctrl+Alt+Right/Left Arrow

Increase/Decrease Leading U Down/Up Arrow Alt+Down/Up Arrow

Increase/Decrease Leading 5× z U Down/Up Arrow Ctrl+Alt+Down/Up Arrow

Increase/Decrease Text point size z X . or , Ctrl+Shift+. or ,

Increase/Decrease Text point size 5× z U X . or , Ctrl+Shift+Alt+. or ,

Increase/Decrease Word space z U \ or Delete Ctrl+Alt+\ or Backspace
Increase/Decrease Word space 5× z U X \ or Delete Ctrl+Shift+Alt+\ or Bckspc
Reset font style (to “Regular”) z X Y Ctrl+Shift+Y

Reset kerning and tracking to 0 z U Q Ctrl+Alt+Q

Reset horizontal text scale to 100% z X X Ctrl+Shift+X

Reset vertical text scale to 100% z U X X Ctrl+Shift+Alt+X

Special characters
Bullet U 8 Alt+8

Copyright Symbol U G Alt+G

Registration Symbol U R Alt+R

Em Dash U X – Alt+Shift+ –

En Dash U – Alt+ –

Ellipsis U ; Alt+ ;

Right Indent Tab X Tab Shift+Tab

New index page reference z 7 Ctrl+7

Add new index entry z U X [ Ctrl+Shift+Alt+[

Display views
Fit Selection in Window z U = Ctrl+Alt+=

View Scale 50%, 200%, 400% z 5, z 2, z 4 Ctrl+5, Ctrl+2, Ctrl+4

Toggle current/previous view scale z U 2 Ctrl+Alt+2

Force screen redraw X F5 Shift+F5

Clear Object-Level Settings z X F2 Ctrl+Shift+F2

Presentation Background: Black/White B or W B or W

Show/Hide Conveyor U B Alt+B

Page navigation
Next window z ` Ctrl+Tab, Ctrl+ ` 

Previous window z X ` Ctrl+Shift+Tab

First Spread U X Page Up, Home Home

Last Spread U X Page Dn., End End

Next Spread U Page Down Alt+Page Down

Previous Spread U Page Up Alt+Page Up

Panel tricks
Show/Hide all panels Tab Tab

Show/Hide all panels except  
Tools and Control

X Tab Shift+Tab 

Open/Close all docked panels z U  Tab Ctrl+Alt+Tab

Activate last-used field in panel z U ` Ctrl+Alt+`

Jump to Control Panel z 6 Ctrl+6

Switch Character and Paragraph  
Modes in Control Panel

z U 7 Ctrl+Alt+7
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