
— WEBINAR —

Photoshop + Illustrator + InDesign: 
Three Apps Working as One

Bart Van de Wiele



The Essential Resource for Design Professionals

If you are a graphic designer, publisher, or production 
artist, CreativePro Network is here to support you with 
resources, knowledge, and a community to help you 
master the tools and raise your skill set to the next level.

Since 1999, CreativePro Network (CPN) has provided 
essential how-to training for users of Adobe InDesign, 
Photoshop, Illustrator, Acrobat, Microsoft PowerPoint, 
and more.

The industry is changing faster than ever, and new 
products and techniques emerge every day. CreativePro 
Network helps you stay current and ensures you continue 
your professional development.

CreativePro.com is the cornerstone of CreativePro 
Network’s wide platform of information resources with a 
collected annual reach of over 5 million readers.

Our philosophy — Learn, Create, Share — drives us to 
provide year-round, full-circle learning to support your 
creativity and career.

Our full range of products include:

	X CreativePro Membership – Grow and stay current with 
member‑only discounts, downloadable templates and 
scripts, weekly how-to newsletters, access to our forums, 
and more.

	X CreativePro Magazine – Monthly PDF magazine with 
in-depth features, reviews, and tutorials you need to 
master the tools of design.

	X CreativePro Events – Learn mind-blowing tips, techniques, 
and best practices from the industry’s top experts.

	X CreativePro Week – Our annual event covering InDesign, 
Photoshop, Illustrator, Acrobat, PowerPoint, and more.

	X CreativePro Books – Essential books and ebooks for 
creative professionals.

	X And more… Thousands of tips and tutorial articles, 
hundreds of podcasts, interactive online courses, instruc-
tional YouTube channels, and thriving community groups 
on Facebook and LinkedIn.

https://creativepro.com/?utm_medium=Ad&utm_source=WebinarHandout
https://creativepro.com/sp/become-a-member/?utm_campaign=Membership&utm_medium=Ad&utm_source=WebinarHandout
https://creativepro.com/issues/?utm_campaign=Magazine&utm_medium=Ad&utm_source=WebinarHandout
https://creativepro.com/events/?utm_campaign=CPEvents&utm_medium=Ad&utm_source=WebinarHandout
https://creativeproweek.com/?utm_campaign=CPW24&utm_medium=Ad&utm_source=WebinarHandout
https://creativepro.com/product-category/book/?utm_campaign=Books&utm_medium=Ad&utm_source=WebinarHandout


https://creativeproweek.com/?utm_campaign=CPW24&utm_medium=Ad&utm_source=WebinarHandout


Photoshop-InDesign-Illustrator as One
Bart Van de Wiele
www.bartvdw.com
Twitter @bartvdwiele

Adobe Photoshop CC techniques
Using native file formats like .PSD files when working with InDesign and Illustrator can give you huge benefits, under the 
right circumstances. Let’s take a look at a few examples.

Using Layer Comps
You can save multiple iterations of the same Photoshop document by saving something called a Layer Comp into the file. A 
Layer Comp represents a set of layers with specific properties, allowing you to save different versions of a design in the same 
file. For example, say you want to create a version of your design where some layers are hidden and others are revealed, or 
where a layer is positioned differently, or where a layer is using a different Layer Style. It’s possible to save all these different 
versions as a named preset, which we call a Layer Comp.

Layer Comps are interesting because they can be referenced when placing the .PSD file into Adobe InDesign, Illustrator or 
other Photoshop documents. To build a Layer Comp, follow these steps:

1. Choose Window > Layer Comps.

2. Click the “New Layer Comp” button at the lower right of the panel.
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3. Clearly name your Layer Comp and choose the appropriate options. 
E.g. choose whether you want to “record” the current layer visibility, 
location or layer styles.

4. Click “OK” to close.

5. Now update the layers in your Photoshop document to represent a 
second version of your file. E.g. by hiding or revealing specific layers, 
changing the settings of a Drop Shadow effect, or moving a layer to a 
different position.

6. Now repeat the steps above to create additonal Layer Comps. 
 

7. Save your document.

To reference a saved Layer Comp from InDesign, follow these steps:

1. Choose File> Place and navigate to your .PSD file.

2. Make sure “Show Import Options” is selected and place the file.

3. From the import options dialog box, choose the appropriate Layer 
Comp. 

4. Optionally, you can always switch Layer Comps by selecting the placed 
graphic and choosing Object > Object Layer Options. 
 

Reusing paths from Adobe Photoshop
I’m sure every designer has used clipping paths before in Adobe Photoshop. 
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These are commonly used to isolate objects from an image. E.g. for product 
catalogs. There’s a specific option in Photoshop called “clipping path” which 
will be applied by default to isolate the layer when placing in InDesign. 
However, InDesign users can access and use ANY saved path from a placed 
PSD, without having to save the path as a clipping path in Photoshop first. 
This is great since every Photoshop document can only hold a single clip-
ping path at a time.
Here are the Adobe Photoshop steps:

1. Create a path using the Pen tool.

2. Choose Window > Paths to view your path. 
 

3. Double click the path in Photoshop to save and name it. 
 

To reference the Photoshop path from InDesign:

1. Place the Photoshop document into your layout. 

 

2. Select the placed image using the Selection tool.

3. Choose Object > Clipping Path > Options.

4. From the options, choose the Photoshop path you’d like to use. 
 

5. Optionally, you can also use the path when applying Text Wrap.

6. Optionally, you can also convert the clipping path into a graphics 
frame by choosing Object > Clipping Path > Convert Clipping Path to 
Frame.
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Hiding layers in a placed document
Similar to using Layer Comps is the ability to show or hide individual layers 
from a placed Photoshop file in InDesign. This could be interesting when 
placing a multi-layered Photoshop document of which you’d like to hide 
or show specific layers, without altering the original Photoshop document. 
Keep in mind that this technique also works with placed Adobe Illustrator 
.AI files. To edit layers, follow these steps in Adobe InDesign:

1. Select the placed graphic.

2. Choose Object > Object Layer Options. 
 

3. Click the eye icon to hide or reveal Photoshop layers.

Creating animated GIFs for Publish Online
It is very easy to create an animated GIF in Adobe Photoshop to use and 
export using InDesign Publish Online. This can be a good way to e.g. create 
callout in your document, without having to mess around with InDesign’s 
multi-state objects and animations. 

Here’s how it works in Adobe Photoshop:

1. Create a Photoshop document that has all the frames of your animated 
GIF as separate layers. In this example there is one layer where the bill-
board shows a text message, and another layer that shows the same 
billboard showing a different text message. 
 

2. Choose Window > Timeline.

3. From the Timeline actions, choose “Create Frame Animation”. 
 

4. Click the Timeline panel menu and choose “Make Frames from Layers” 
to convert every individual layer into a keyframe. 
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5. Change the timing of individual frames as required by clicking on 
every individual frame and choosing timing options. 
 

6. Choose File > Export > Save for Web (Legacy).

7. Make sure GIF is selected and set the looping options at the bottom of 
the screen. 
 

8. Now place your animated GIF into Adobe InDesign and use the Publish 
Online feature (or Fixed Layout ePub) to view it.

Recolor grayscale images
A very old, but still fairly unknown, technique is the ability to recolor gray-
scale images in Adobe InDesign. This is a technique where we’ll take a 
single-ink grayscale image and recolor it in Adobe InDesign by replacing 
the black ink with a different printing plate, e.g. a spot color. This technique 
is especially interesting when creating monotone or duotone designs using 
Trumatch or Pantone inks.

Start out in Adobe Photoshop:

1. It’s important your image only has one color channel. Choose Image > 
Mode > Grayscale to clear out all color channels (except gray). 
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2. Save your document as a .PSD, .JPG or .TIF file.

3. Place your document in Adobe InDesign.

4. In Adobe InDesign, click the content grabber to select the graphic 
frame contents. Notice the fill color becomes black.

5. Change the fill color using the Swatches panel, here we choose a Pan-
tone color. You can even use regular swatches that only use process 
colors if needed. 
 

Pasting Illustrator files in Photoshop
Placing artwork from Adobe Illustrator into Adobe Photoshop is an action 
that most designers have already done a million times before. But we’re 
often so used to a specific technique that we sometimes forget that this can 
be done in a variety of ways. Ways that can sometimes give us more flexibil-
ity when placing or updating artwork, or save us a bit of time.

The main methods of getting Illustrator artwork into Photoshop is by:

1. Pasting artwork, or dragging and dropping it from Illustrator into 
Photoshop.

2. Placing the artwork using the Place Linked or Place Embedded com-
mands in Photoshop.

3. Using a Creative Cloud Library.

When you paste artwork from Illustrator into Photoshop, you have a few 
options available. Let’s take a look at the most important ones: 
 

• Paste as a Smart Object to embed the artwork in Photoshop, but still 
having the option of editing the copied artwork in Illustrator. Note that 
this is a copy of the Illustrator artwork.

• Paste as Layers to convert Illustrator’s native artwork into Photoshop 
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shape layers. Note that this does not support many of Illustrator’s object 
types, including text layers, clipping groups, symbols and many others. 
Consult the help documentation for details.

• Paste as Pixels to rasterize all content as it is brought into Photoshop.

It’s important to note that copying and pasting will only bring in the 
selected artwork from Illustrator and not the artboard itself (or art from 
other artboards).

Placing Illustrator files in Photoshop
Placing an Illustrator file (as opposed to pasting) will place the entire docu-
ment into Photoshop. This means that all artwork in the placed Illustrator 
document will travel with the Photoshop file (assuming you keep your live 
links intact). While pasting will only bring in the artwork that was initially 
selected from Illustrator.

Placing and embedding an entire Illustrator document in Photoshop can 
be very easily achieved:

1. In Photoshop, choose File > Place Embedded.

2. Navigate to your Illustrator document and double-click it.

3. From the Place dialog box, choose the artboard you wish to place and 
confirm. 
 

4. Position the artwork on the canvas and press Enter to confirm.

5. Notice the Smart Object icon of the placed layer. 
 

Additionally, you can also choose to link to the original Illustrator file 
(exactly the same way InDesign manages placed images). The advantage of 
placing and linking is that the original Illustrator file can be linked to other 
documents as well, all linking to the same source.

Placing and linking an Illustrator document in Photoshop is just as easy.

1. In Photoshop, choose File > Place Linked.

2. Navigate to your Illustrator document and double-click it.

3. From the Place dialog box, choose the artboard you wish to place and 
confirm.

4. Position the artwork on the canvas and press Enter to confirm.

5. Notice the linked Smart Object icon of the placed layer. 
 

Additionally, you can convert the linked Smart Object into an embedded 
one using the Properties panel. And it’s even possible to package your work, 
just like in InDesign. To achieve this, choose File > Package.
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Adobe Illustrator CC techniques
Here are a few examples on how to best combine Illustrator with InDesign.

Extracting multiple assets from a design
When you have an Adobe Illustrator file of which you’d like to place mul-
tiple, individual assets into Adobe InDesign it’s always a good practice to 
extract them. And since it’s not done to copy and paste over logos and 
other artwork to InDesign all the time, we need to have these assets as sepa-
rate links for easy management. Here’s what you do in Adobe Illustrator.

1. Choose Window > Asset Export

2. Now use any of the following techniques:

• Select the object you want to export and drag it into the Asset 
Export panel

• Select the asset and right-click, then choose Collect for Export > As 
Single Asset.

• Select multiple assets (group multiple objects to add them as a 
single entry) and right-click, then choose Collect for Export > As 
Multiple Assets.

3. Optionally, double click the names of the assets and name them. 
 

4. Change Scale settings, and add extra Scales if needed to configure the 
output.

5. When done, click the “Export for Screens” button.

6. Set additional options and check all assets that you wish to export at 
once. 
 

8 of 16

Photoshop-InDesign-Illustrator as One
Bart Van de Wiele

WASHINGTON DC + ONLINE  2022

July 8–12, 2024    Washington, DC + Online    CreativeProWeek.com   |   8

CreativePro Webinar 
Photoshop + Illustrator + InDesign: Three Apps Working as One

Bart Van de Wiele

https://creativeproweek.com/?utm_campaign=CPW24&utm_medium=Ad&utm_source=WebinarHandout


7. Choose “Export Assets” to close and export.

8. Optionally, you can also export artwork per artboard instead of object. 
You can find these options in the “Export for Screens” window.

Working with multiple artboards
I can’t stress enough how using multiple artboards can help you with your 
workflow. Not only does it offer you many advantages when working in 
Adobe Illustrator alone. You can also use and update these artboards when 
placing a native .AI document in Adobe Illustrator.

Never forget that an .AI document is basically a PDF file. So when you’re 
using multiple artboards in Adobe Illustrator, you’re basically placing a 
multi-page PDF document in Adobe InDesign. Thanks to multiple artboards, 
you can place illustrations on separate artboards and later choose which 
one to place in Adobe InDesign. This is easy because this way you can save 
a whole series of illustrations in just one file. This makes managing, sharing 
and updating assets easy. You can even save multiple color versions of a 
logo in one Illustrator document. For example save a CMYK and a Pantone 

version of the same logo, but on a separate artboard. Here is how you place 
a multi-artboard Illustrator document in Adobe InDesign:

1. In Adobe InDesign, choose File > Place.

2. Select the .AI file you wish to place and make sure import options are 
active before placing.

3. From the Import Options dialog box, choose the appropriate page and 
set the cropping options (if needed). 
 

4. Place the graphic.

5. Notice that it is not really possible to switch PDF pages after the file has 
been placed. So in order to replace the graphic with a different page 
from the same file, select the graphic first and go through the same 
steps to replace the graphic.

6. Notice that the links panel will show you which page was placed.

Changing to a different artboard after placing

1. Select the placed graphic.

2. Choose File > Place and select the same Illustrator file, make sure 
“Show Import Options” is still activated.

3. Choose a different artboard and choose OK to place.
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4. Alternatively, you can relink the file using the Links panel.

Advantages of placing as Artboards in InDesign
• It’s very easy to view and choose the artboard you want during placing 

in InDesign.

• The “Crop to” option during placing allows you to either place the art-
work or use the artboard as a bounding box (e.g. as padding around a 
logo or icon).

• The Links panel in InDesign will always show you the artboard# as well.

• Updating any of the artboards in Illustrator by directly editing the art-
work, adding/removing/renaming artboards will not confuse InDesign 
when updating.

• Artboards are a great way to organize your artwork in Illustrator and 
even enables:

 - The ability to save every artboard as a separate AI file.

 - The ability to export to various files, using the artboard names as file 
names.

 - The ability to nest a specific artboard into another Illustrator file.

 - The ability to place a specific artboard into a Photoshop document.

Disadvantages of placing as Artboards in InDesign
• You can’t see the artboard names when placing in InDesign or 

Photoshop.

• Changing to a different artboard in InDesign requires you to re-place 
the original file. Which is not the greatest experience.

Advantages of overriding AI layers in InDesign
• You can see the name of the Illustrator layers while placing.

• Changing to a different layer can be easily done from within InDesign.

• Since layers are often used during the design process of artwork in Illus-
trator anyway, there are often no extra steps required to make the file 
“InDesign-ready”.

Disadvantages of overriding AI layers in InDesign
• You can only access the top-level layers from InDesign, no sub-layers.

• Altering the layer structure of an Illustrator document after placing 
in InDesign (with overwritten layers) will cause your file to reset in 
InDesign. This happens when you change layer order, add, rename or 
remove a layer in Illustrator. 
This means that you sometimes unknowingly introduce problems in 
InDesign. 
E.g.: you have an Illustrator file with a layer called “blue” and a layer 
called “green” and place that file in InDesign with only the blue layer 
visible. You then add a layer called “red” in Illustrator and save the file. 
Upon returning to InDesign you’ll be greeted with a message that 
explains that the layer structure has changed since placing the file, and 
so InDesign will revert the file back to the original layers.  
This is exactly why I used logos in this exercise for layers, since those 
don’t tend to change once created.

Placing a cloud document
Creative Cloud allows you to save Photoshop and Illustrator documents as a 
cloud file, as opposed to a local file on your hard drive or server. This means 
your documnet will leave no traces on your hard drive and will be saved in 
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the Creative Cloud storage as either a PSDC or AIC document, respectfully.
Saving documents as cloud documents, as opposed to local documents, 

comes with a few advantages. It gives you the ability to share the design 
with others, allowing them to comment and annotate the file directly, or 
save multiple versions of the same document.

In addition to this, you can also place cloud documents into other apps. 
While this functionality is still being further developed by Adobe at the time 
of writin this handout, there are already a few possibilities available. To place 
a Photoshop cloud document in Illustrator, follow these steps:

1. In Photoshop, open the file you wish to save as a cloud document.

2. Choose File > Save As, and when prompted, choose Save To Creative 
Cloud. 
 

3. Name the file and confirm. Notice the cloud icon next to the file name, 
clearly showing this is a cloud document.

4. Return to Illustrator.

5. Choose File > Place.

6. From the Place dialog box, click Open Cloud Document.

7. Illustrator will display all of the Photoshop cloud documents curently 
saved in the cloud or shared with you via others. 
 

8. Select the file(s) you wish to place.

9. At the bottom of the screen, choose whether you wish to embed or 
link the cloud documents.

10. Click Place to import the documents.

11. From the Place options, choose your desired settings. 
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12. Notice how the file is clearly listed as a cloud document from the 
Links panel. 
 

 Using Creative Cloud Libraries
Creative Cloud Libraries open up the Adobe eco-system by offering a way of 
passing different asset types from one app to another. And the system can 
be defined by the following three differentiators:

1. Interoperability: The libraries are not just limited to Photoshop,  
InDesign or Illustrator alone, they are available within every Creative 
Cloud application (even Microsoft Office 365!). They also give you 
the ability to link assets to multiple projects across multiple apps to a 
single source of truth. 
E.g., you can link Illustrator artwork to a Photoshop document for a 
web banner, to an InDesign document for a magazine, to Adobe XD 
for a UX project and to Premiere Pro for a video project, all at the same 
time. And updating the asset will update all those projects.

2. Asset types: “Why should my company invest in yet another cloud solu-
tion? We already use Dropbox (SharePoint, Google Drive, or others).” This is 
a common question asked by Adobe customers. The answer is that any 
other cloud storage provider only offers the ability of storing regular 
files like JPG, PSD, AI, INDD and others. While a Creative Cloud Library 
is specifically designed to host design assets which do not have a 
dedicated file format. How do you save a paragraph style as a separate 
file? You can’t ... How do you save a Photoshop layer style as a separate 
style? You can’t ... This is the unique differentiator for Creative Cloud 
Libraries.

3. Collaboration: Another differentiator when choosing between saving 
and placing local assets in PS, IL or ID versus a Creative Cloud Library 
is the fact that you can share the library with other users. This means 
you can create a “curated” library of design assets for your marketing 
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department, a freelancer, or a team member that only holds the con-
tent you have made available. Either as a read-only or full access file. 
This avoids your IT department giving server access to externals, or 
you having to send large quantities of data.

Linking live text via CC Libraries
Since Oct 2017 it is possible to save text from InDesign into a CC Library as a 
live text element instead of a formatted graphic. The main advantage to this 
is that the text is stored as live text and not as a graphic.

If you save a text frame as a graphic (instead of live text), it’s not possible 
to maintain a live link between the text frame an your InDesign projects. It’s 
an interesting technique that allows you to place multiple instances of the 
same text frame in one or multiple InDesign documents and then update 
the text in all of them at the same time. And because Adobe Illustrator and 
InDesign share the same text engine, you can even reuse the text in either 
programs. Do keep in mind that maintaining a live link to text is an InDesign 
feature which is not available when using Adobe Illustrator (though there 
are workarounds that work but aren’t very user friendly). 

How to use a text element using Adobe InDesign:

1. Create a text frame and add text to it.

2. Drag and drop the text frame into the CC Libraries panel to save it 
as a Text element. Alternatively, select it and click the plus icon, then 
choose Text 

3. To reuse the element in Adobe InDesign, drag and drop the element 
onto your InDesign document. It’s also possible to place the text ele-
ment unlinked or without formatting. Right-click the element from the 
CC Libraries panel and choose the appropriate option for this. 
 

4. To reuse the element in Adobe Illustrator, drag and drop the element 
onto your Illustrator document. Notice that a live link is not supported 
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for text elements in Adobe Illustrator. So linked edits aren’t possible.

5. Double click the text element from the CC Libraries panel to edit the 
text using the original application (InDesign or Illustrator).

Keep in mind that while text can be linked to the CC Library when using 
Adobe InDesign, the text frame itself is not linked. This means that you can 
always update the linked text contents but the text frame itself will remain 
unchanged after the update (allowing custom formatting). 

Also keep in mind that many text features in Adobe InDesign aren’t sup-
ported in Adobe Illustrator e.g. tables or custom stroke styles. These will be 
“numbed down” to their Illustrator equivalents or will disappear altogether.

Saving grahics in a CC Library
The easiest way to add anythinig to a Creative Cloud Library is by selecting 
it and then dragging and dropping it into the Libraries panel.

You can find the Libraries panel in Photoshop and Illustrator by choosing 
Window > Libraries. And in InDesign by choosing Window > CC Libraries. 

Dragging and dropping artwork from Illustrator or Photoshop will save 
and embed a copy of the artwork into the library. However, InDesign is a bit 
more specific as it saves all content in the library as an InDesign snippet. This 
is fine for native artwork like text and vector shapes. But since images are 
placed and linked into InDesign, it will only store the low-resolution preview 
in the library instead of the full-resolution graphic.
Saving images into a library will give you a different result depending on the 
application you’re using.

• When you drag placed images from InDesign into the Libraries panel to 
save and re-use them in another InDesign document they’ll be used as 
InDesign Snippets. And these will still reference the original location of 
the placed image (offline local link). If the original referenced image isn’t 
available when reusing the asset, a missing link will occur.

• When you drag images from Photoshop or Illustrator into the Libraries 
panel and then use them in InDesign they’ll be linked as online assets.  
So the actual image itself is stored in the library, not just the link to it on 
your HD. 

Saving text styles
You can save your Character- and Paragraph styles in a library in Adobe 
InDesign. Saving your styles can be done in 2 ways:

• Put your text cursor in the text that is using the style and then click the 
“Paragraph style” button in the libraries panel. 
 

 

• You can also add it directly to the library while creating the style.

Clicking the style in the libraries panel will apply it and copy it to the librar-
ies panel. Do keep in mind that the style is copied over to the new docu-
ment when applying it and there is no live link. This means that changes to 
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the style will not be applied to the library nor to other documents where 
the same style was used. 

Careful when saving Paragraph Styles from Adobe 
InDesign into a CC Library
Some applications, like Photoshop, only have the ability to use Character 
Styles via the libraries panel. And even though Photoshop does have a Para-
graph Styles panel, it can only use Character Styles from the Libraries panel. 
This means that when you want to reuse your text styles in Photoshop, you 
need to create a Character style instead. The same counts for the video apps 
like Premiere Pro or After Effects.

Saving colors
Saving colors is just as easy as everything else. Note that libraries support 
both individual colors and color themes e.g., from Adobe InDesign or Adobe 
Capture CC - the mobile app.

Clicking a saved color will add this color as a swatch to an Adobe InDesign 
document, but won’t in Photoshop or Illustrator where it will only apply 
the color instead. It’s important to learn these differences when managing 
branded assets in multiple programs. 

Careful when saving colors into a CC Library
Libraries support RGB, hex and CMYK colors. But 
remember that colors are added the way they 
were built. Hover over a library color to see the 
name of the color, its hex value, and then the 
original color values (which sometimes can be a 
bit confusing.)  

In this InDesign example, the gray color was originally CMYK but was 

converted to RGB so it could be used in a Publish Online project. And 
though the original name of the swatch is still implying it’s a CMYK swatch, 
it actually isn’t. Notice the actual RGB color values at the bottom of the yel-
low pop-up. 

Updating assets via Creative Cloud applications
When you drag an item from the library to your page or artboard remember 
to keep an eye out for that little library icon. This means the asset is linked 
and can be updated globally across multiple applications and documents.

This icon can appear in Adobe InDesign where you’d usually see the link 
icon when using images. 
 

And it can also be seen in the Links panel itself. Make sure that you’re 
online and you see this library icon when printing or exporting to hires PDF 
from Adobe InDesign. 
 

Notice that you can also place unlinked copies of the same graphic in 
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most design applications. Hold down the Alt (Option) key while placing the 
image from the library, or alternatively you can right-click and choose “Place 
Copy” instead of “Place Linked”.

Updating CC assets
• For colors, you can right-click the swatch in the CC Library and choose 

“Edit”. Note that this will only update the CC Library item and not the 
document(s) in which it was used since there is no live link.

• You can double-click InDesign snippets to edit and update it in InDesign 
and save it back into the CC Library. Note that this will only update the 
CC Library item and not the document(s) in which it was used since 
there is no live link.

• Text styles need to be recreated and added to the library after which 
you then manually delete the old asset. You can do this by dragging the 
item to the panel trash icon.

• When you have saved images and vector shapes from Adobe Illustrator 
or Adobe Photoshop you can double-click the asset in the libraries 
panel to open the original. When you then edit and save the asset it will 
overwrite the original and update all linked instances in all applications 
and documents.

Replacing CC assets
Replacing assets is similar to updating assets but not entirely:

• For colors, text styles and InDesign snippets, see above.

• Using either the Links panel in Adobe InDesign or Illustrator, or right-
clicking a layer in Adobe Photoshop – you have the option to replace the 
item with a library graphic. When doing so the program will give you the 
option to choose a different asset from the libraries panel as a replacement. 

 

Transferring swatches from Photoshop and 
Illustrator to Adobe InDesign
There’s another way for copying Photoshop and Illustrator swatches to 
Adobe InDesign, without even using CC Libraries. For this we can use an ASE 
file which stands for Adobe Swatch Exchange. These files can be used in 
multiple CC applications, and even Adobe Bridge can preview them. 

However, there are limitations. You cannot share the following types of 
swatches between applications: patterns, gradients, mixed inks and tints, 
and the Registration swatch from Illustrator or InDesign; and book color 
references, HSB, XYZ, duotone, monitorRGB, opacity, total ink, and webRGB 
swatches from Photoshop. These types of swatches are automatically 
excluded when you save swatches as an ASE file..

• To save an ASE file from Illustrator, click the Swatches panel menu and 
choose “Save Swatch Library as ASE”.

• To save an ASE file from Photoshop, click the Swatches panel menu and 
choose “Save Swatches for Exchange”.

• To load an ASE file into InDesign, click the Swatches panel and choose 
Load Swatches. Then select the ASE file to use.
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