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What is an Anchored Object?
Anchored objects are objects, such as images or text frames, that are attached—or anchored—to specific text. The 
anchored object will travel with the text to which it is anchored as the text reflows between columns or pages. 
Use anchored objects for all objects that you want to stay with a particular line or block of text, for example, sidebars, call-
outs, figures, photos or icons which must stay with a specific word or line.

This is an example of some text 
into which you can anchor an 
object next to.

This is an example  of 
some text into which you can 
anchor an inline object. You 
can put a graphic INTO the 
text which will travel like a 
character.

Hanging, Anchored Object

Graphic hangs inside  
or outside  

of the text frame

Inline Graphic

Graphic moves with 
text like a character
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Why would I anchor an object?
To keep any object traveling with text. When the text moves from column to column or page to 
page, any object which is anchored to text will also move, traveling along with the text. 

What types of objects can be anchored?
Anything that can be placed into an InDesign Frame: • Photo or Icon in a Graphic Frame • Text in a Text 
Frame • Frames with color and no content  • Group of any number of InDesign frames.

Wondering what you can use anchored objects for? Here are a few ideas.

• Anchor an icon (social media) in front of a name         Laurie Ruhlin
• Anchor a logo, icon, photo or graphic in place of text (kids book) or logo in  text

• Anchor a Drop Cap at the beginning of a story, an icon 
indicating the end of a story or a pull quote

• Anchor a graphic, figure, diagram to a paragraph of text

• Anchor a photo next to the bio or description of that photo

• Anchor a photo of a person in a phone directory next to or 
above the name

• Anchor an icon or any graphic into a table cell 

When you Anchor an object, it will react in 
two different ways

• Anchored Graphic Graphic is Anchored to a paragraph, 
but hangs inside or outside of the text frame. This graphic 
can be moved around the page, but it still remains 
anchored to the spot where you dragged it. 

• Inline Graphic The object acts like it’s a character. It can’t 
be moved around the page, only in the line into which it’s 
anchored. 

Anything can be anchored 
as long as it’s one frame,  

or a group.
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How to Anchor a Graphic

Anchored Graphics 
Object is connected to the text, but free floating, can be placed anywhere on the page.

• Using the Selection Tool, select a frame, click and drag the little blue square*, (located at the top 
right of the frame) into text. 

• The Anchored Object is able to be positioned anywhere, but will travel with the line of text into 
which it was anchored. 

Inline Graphic
Object will anchor and travel in a line of text, like a character

• Using the Selection Tool, Hold the SHIFT key then drag the blue box at the top right corner of a 
frame or a group, in between two characters, release the SHIFT key after releasing in the text. 

• Graphic is an INLINE graphic, and remains in between the text characters. The graphic acts like a 
character.

• Use the Selection Tool to move the Inline Graphic up and down from the baseline of the text.  
It can’t be moved further up or down further than the baseline, can’t move left or right at all. 

Anchor a graphic with a cursor in your text
• With your cursor blinking in text, choose File > Place. Choose a graphic, icon, photo etc. 

• Your placed graphic will automatically be an Inline Graphic. 

• I usually do this method by mistake - be careful. If the graphic is too large, you might overset your 
text and not be able to see the large graphic. I believe that you have better control by placing and 
sizing the graphic first, then anchoring it - by dragging it into the text, holding the Shift key. 

Anchored Graphic
Click and drag the little blue square 
at the top right of the frame into 
text. Graphic is able to be positioned 
anywhere. 

1

*Note: In my notes and presentation, I’ll be saying drag the “little BLUE anchoring 
square”. As a default, it is light blue because it’s on the default Layer 1. If you change 

layer colors, or put an object on a different layer, your square might be a different color.

Inline Graphic (SHIFT Key)

Hold the SHIFT 2  key while dragging 
and releasing the same blue box. Graphic 
is an INLINE graphic, and stays with the 
text as a character.
Here is a logo ACME

DOG TRAINING
 example of an 

inline graphic. 

2

Logo before Anchoring

Logo after Anchoring. Notice the Anchor 
Icon and the dotted line showing exactly 
where it has been anchored. (View > Extras 
> Show Text Threads). You’ll also see a ¥ 
symbol showing the location of the anchored 
graphic.
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Anchor Icons into text
Let’s create a list of Parks, with icons after the park names, as Inline Graphics. If the park names are  
re-ordered or renamed or the icons are changed, each icon doesn’t have to be manually moved. 

1. Type in the names of the Parks, use a Return/Enter after each name. 

2. Place the icons on the page, using Gridify. (File > Place, choose multiple icons, click OK. Click and 
drag the mouse, hit the up & down and/or right & left arrows to create a grid. Release the Mouse)

3. Add a few spaces after each park name. You can drag each icon between these spaces. 

4. Turn on Drag and Drop.  
Choose Preferences > Type - Drag and Drop Text Editing    Enable in Layout View.

5. Select a single icon with Selection Tool. Hold the Shift Key. Click and drag the little blue square 
between the spaces after a park name. Release the mouse, then release the Shift Key. Repeat for 
each icon, leaving a space (optional) between each icon. 

6. With the Selection Tool, drag each icon up or down to line up where you want it.  
Or use the down arrow key to move it a specific number of points.  (or see #8)

7. To change the order of the icons, with the Type Tool, select the icon and a space, then drag the 
selected “letters” (because icons are acting like a character) to a different location in the text. 
After you start to drag and drop the text, you can hold the Option (mac) or Alt (win) key to copy. 
This works because you turned on Drag & Drop in Preferences > Type. (#4)

8. Note: If there are many icons to place, create a Character Style for the icons to control the Track-
ing and Baseline Shift. Apply this character style only to the icons, selected with the Type tool to 
change the spacing and vertical location of the icons for the entire document.

9. If the order of parks need to change, triple click on the paragraph, then drag the entire paragraph 
to a different order - and all the icons travel with it, because they are like characters after the park 
name. 

Social Media Icons

• Anchor a social media icon in the same manner. Select an icon, hold Shift, drag icon before the 
word “Facebook”. Add in a space or em space between the icon and the words. 

• Select the icon with the selection tool, drag or use the arrow keys to position.

 Facebook

 Instagram

 Twitter

 Yelp

Entertainment at the Parks

Independence Park 

Stadium Park 

Horizon Nature Center 
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Anchor a graphic so it hangs outside of the text frame
If you have an icon, photo, group or text frame that needs to stick with a name or paragraph of 
text, you can anchor it and allow the graphic to hang outside of the text frame. The best way to 
control the placement of multiple anchored graphics would be to create an Object Style to control 
the exact size of the graphic, attributes (stroke, shadow etc) and the distance from the text frame.

To Anchor and hang a graphic outside of a text frame

1. Type in a list of text, names, or paragraphs. Format. 

2. Place your photos or icons on the page, use gridify to make them all the same size.

3. Select one graphic with the Selection Tool and drag the little blue square into the line of text 
with which it should travel. 

4. Using the Selection Tool, drag to move the graphic anywhere in relation to the text frame. 

5. Choose View > Extras > Show Text Threads to show the dotted line from the anchored 
object to the text into which it has been anchored.

6. Choose Object > Anchored Objects > Options to position it perfectly. (see graphic)

7. Create an Object Style to save the exact location of the object relative to the text. Apply tohe 
Object Style each time a new object is anchored into the text. 

Where should you drag the anchor?  
Don’t release the anchor in the middle 
of a word, because Find or Spell Check 
won’t recognize it as a word. I like to 
drag the anchor to the END of the line 
of text. If I need to select the entire 
block of text, I’ll be sure to select the 
anchor. If it’s at the beginning of the 
paragraph, sometime it will be missed 
in the selection. 

Karen Dineen Adams, M.D.
Child Psychology
301 State Blvd
Galveston, TX 77555-0188 
PH: (409) 555-8330
kwagner11@utmb.edu

Art Walas, M.D., M 1552
Dept of Psychiatry
6001 Ress Park Blvd
Madison, WI 53719 
PH: (608) 555-6106
awalask@wisc.edu

Roger Dale Walker, M.D., M 0769
Dept of Psych,  (GH-155)
3181 SW Sam Jackson Park Rd
Portland, OR 97239 
PH: (503) 555-3703
walker@ohsu.edu

Anchored Position Reference Point indicates 
the left side of the photo.

X Relative To - can choose Text Frame, Anchored position etc. 
The X offset value will move the anchored object left (positive) 
and right (negative). The value of .1” says that the top right 
corner of the photo is .1” to the left of the text frame. 

Y Relative To - can choose Text Frame, Line (Baseline), An-
chored position etc. The Y offset value will move the anchored 
object up (negative) and down (positive). The value of -.1” says 
that the top right corner of the photo is -.1” above of baseline 
of the line of text in which you dropped the anchor.
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Anchor a Photo into a story - To Wrap or Not to Wrap
A common use for Anchored Objects is to place a photo, then anchor it in a story and make sure that 
the photo travels with the paragraph that it pertains to - and have the text wrap around it. 

In the example to the right, icons are anchored, and hanging OUTSIDE the frame. Later, we’ll move 
these into the text, and wrap the text around the icon.

For this example I have a paragraph with an Adobe program name in color and a full paragraph 
description formatted as body text. I’ve anchored the icon into the beginning of the paragraph of text. 
We’ll find out the best location to anchor the photo, and how to create an object style to automatically 
place the photo in the correct position.

Hang Outside of the Frame

1. Place Icons on the page. (Use Gridify!) Place and format text. Make a Body Text Paragraph Style. 

2. Select an Icon and drag the blue anchor box into the text, to the beginning of the body text 
paragraph.

3. Select the Icon and drag to position it to the left of the body text frame. 

4. Open Window > Styles > Object Styles panel. Choose New Object Style from the panel menu. 
Name the style and click OK. Don’t forget to apply the style to the selected Icon (or make sure to 
check mark Apply Style to Selection in the Object Styles dialog before clicking OK). 

5. Anchor another Icon into the next body text and apply the Object Style to precisely position the 
photo to the left of the text. 

6. You may have to visit Object > Anchored Objects > Options (or, better yet, open the Object Style 
and modify Anchored Object Options from there) and choose the TOP RIGHT of the icon 
(Anchored Object) to line up with the LEFT side 
of the Text Frame (Anchored Position) you can 
also add a bit of X Offset Space under X Relative 
to:  this moves the icon left or right

7. Repeat anchoring more Icons and applying the 
Object Style. 

InDesign is a desktop publishing and 
layout application for creating books, 
magazines, and brochures, as well as 
print and digital publications. It’s the 
industry standard editing software for 
laying out long-form multi-page docu-
ments, but it’s not limited to that.

Illustrator is a graphic design applica-
tion. Graphic designers use Illustrator 
to create vector graphics. Vector im-
ages and graphics are made of points, 
lines, shapes, and curves based on 
mathematical formulas rather than a 
set amount of pixels.

Photoshop is the industry-standard 
photo editing software, and the go-to 
application for everything from small 
retouching changes to mind-bending 
photo art. Photoshop is where editors 
crop photos, adjust photo composi-
tion, correct lighting, and make any 
subject imaginable look its absolute 
best.

Adobe Acrobat software is the free, 
trusted global standard for viewing, 
printing, signing, sharing, and annotat-
ing PDFs. It’s the only PDF viewer that 
can open and interact with all types 
of PDF content – including forms and 
multimedia.
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Use Text Wrap

1. Place Icons. (Use Gridify!) Place and format text. Make a Body Paragraph Style. 

2. Select an Icon and drag the blue anchor box into the text, to the beginning of the body text 
paragraph.

3. Select the Icon and drag it. Put it over the first few lines, on top of the body text. 

4. Open the Window > Text Wrap panel and choose the second 
button, and increase the offset. Notice how the text will wrap, 
starting at the second line of the paragraph. The first line, the 
one in which you’ve anchored the Icon will not wrap. To solve 
this problem, drag the icon below the first line. 

• Here is the rule about anchoring and text wrap: If you Anchor a photo into the text, without 
making it inline (holding shift) the text in the line that contains the anchor won’t wrap. It has to be 
placed in the paragraph or line above the first line you want to wrap. You could just hold Shift and 
make it inline, but they you don’t have flexibility to place it anywhere you want. (more on this later)

5. Open Window > Styles > Object Styles panel. Choose New Object Style from the panel menu. 
Name the style and click OK. Don’t forget to apply the style to the selected Icon (or make sure to 
check mark Apply Style to Selection in the Object Styles dialog before clicking OK. 

6. Anchor another Icon in the next paragraph and apply the Object Style to precisely position the 
Icon in the text. 

7. You may have to visit Object > Anchored Objects > Options and choose the TOP LEFT of the Icon 
(Anchored Object) to line up with the LEFT side of the Text Frame (Anchored Position). This is nice 
because the Icons may not be the same size. You want to position the top left of the icon to the 
left of the text frame, so if the icon is smaller or larger, it grows to the right and down.

InDesign is a desktop publishing and layout 
application for creating books, 
magazines, and brochures, as well 
as print and digital publications. 
It’s the industry standard editing 
software for laying out long-form 

multi-page documents, but it’s not limited to 
that.

Illustrator is a graphic design application. 
Graphic designers use Illustrator 
to create vector graphics. Vector 
images and graphics are made of 
points, lines, shapes, and curves 
based on mathematical formulas 

rather than a set amount of pixels.

Photoshop is the industry-standard photo 
editing software, and the go-to 
application for everything from 
small retouching changes to 
mind-bending photo art. Photo-
shop is where editors crop photos, 

adjust photo composition, correct lighting, and 
make any subject imaginable look its absolute 
best.

Adobe Acrobat software is the free, trusted 
global standard for viewing, 
printing, signing, sharing, and 
annotating PDFs. It’s the only PDF 
viewer that can open and interact 
with all types of PDF content – in-

cluding forms and multimedia.

7 of 15

Save Time in InDesign with Anchored Objects
Laurie Ruhlin

PHOENIX + ONLINE  2023

CREATIVEPRO WEBINAR
Saving Time in InDesign with Anchored Objects

Laurie Ruhlin

June 2–6, 2025    Phoenix, AZ + Online    CreativeProWeek.com   |   8

https://creativeproweek.com/?utm_campaign=CPW25&utm_medium=Ad&utm_source=WebinarHandout


Are you always using a few icons within your documents? 
If you consistently use an inline graphic/icon(s) in your documents, it can be difficult to size and place 
it every time the same way, or, to find it in an old document. We can save these little icons in our CC 
Library. 

1. Place icon on the page, size it. Holding the Shift key, anchor it as an Inline graphic into your text. 

2. With the selection tool, move the icon up and down to place it exactly how you want it to look, 
comparative to the body text. You can also resize it while it’s anchored as an inline graphic. 

3. Using the Type Tool, drag over the Inline graphic as if it’s a character. Open the CC Library Panel, 
and make sure the library where you want to save this icon is active (or make a new Library)

4. Choose the “+” at the bottom of the CC Library Panel and choose Text. 

5. Name the new library entry.

6.  To Insert this icon into your text, put your cursor where you want it to go. Right click on the Icon 
in the CC Library and choose Place Inline. Repeat every time you want to place it in a new position 
in your text. The graphic is linked to the graphic on your hard drive (when you originally placed it), 
not to a library entry. 

7. I use this for social media icons, program icons, shortcut keys, icons for a specific business, icons 
on menus to indicate vegetarian, spicy etc. 

 is a desktop publishing and layout application 

for creating books, magazines, and brochures, as 

well as print and digital publications.  is the 

industry standard editing software for laying out 

long-form multi-page documents, but it’s not 

limited to that.

 is a graphic design application. Graphic 

designers use  to create vector graphics. 

Vector images and graphics are made of points, 

lines, shapes, and curves based on mathematical 

formulas rather than a set amount of pixels, and 

therefore can be scaled up or down while main-

taining image quality.

 is the industry-standard photo editing soft-

ware, and the go-to application for everything 

from small retouching changes to mind-bending 

photo art.  is where editors crop photos, adjust 

photo composition, correct lighting, and make 

any subject imaginable look its absolute best.

 is the free, trusted global standard for view-

ing, printing, signing, sharing, and annotating 

PDFs.  is the only PDF viewer that can open 

and interact with all types of PDF content – in-

cluding forms and multimedia.
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Drop Caps

Wrap body text around the BOX of Drop Cap
1. Select the Text Frame containing the letter. 

2. Hold the Shift Key. Drag the blue anchor square into the text, at the beginning of the paragraph. 
Release mouse, then the shift key on the keyboard.

3. With the Selection Tool, drag the letters’ frame down into the text. 

4. Window > Text Wrap and choose the second button to Wrap around bounding box.

5. Adjust the size of the frame, or the Text Wrap offset

Wrap body text around the SHAPE  
of the letter

1. Select the Text Frame containing the letter. Choose 
Type > Create Outlines. 

2. Hold the Shift Key. Drag the blue anchor square 
into the text, in the beginning of the paragraph. 
Release mouse, then the shift key on the keyboard.

3. With the Selection Tool, drag the letter frame 
down into the text. 

4. Window > Text Wrap and choose the third button 
to Wrap around object shape.

5. Change the Offset value to push the text further 
from the letter.

6. Under Wrap Options: Choose “Right” or “Largest Area” to make the text wrap only on the right.

A
Cuptus por si sam re 
pelestrum quibusd 
aeritis expellatio. 
Lupta quae consequi 
quatum aut perrovid 
quaesequam volorum 
restini hicidit, conse-

quo omnis arisitis ea volorrovidio eic tempo-
restrum essim ditiorum ne volessit de di 
intemquist, sit evel eatempo saerum num 
aut fugit occum que de nos ad qui ommolo 
dolut volorit, ni untiis sequis ipsam et.

Cuptus por si sam re 
pelestrum quibusd 

aeritis expellatio. Lupta 
quae consequi quatum 
aut perrovid quaese-
quam volorum restini 

hicidit, consequo omnis arisitis ea volorrovi-
dio eic temporestrum essim ditiorum ne 
volessit de di intemquist, sit evel eatempo 
saerum num aut fugit occum que de nos ad 
qui ommolo dolut volorit, ni untiis sequis 
ipsam et pere ide et.
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Anchor a Quote or Graphic in a story
1. Type and format a quote in a text frame. If using multiple frames, group them. 

2. In your story, make an extra return between the paragraphs. This way you can 
align the anchored object left, right or center and apply a paragraph style to the 
placeholder return.

3. Shift drag the anchored object (text, group or graphic frame) into the empty 
paragraph return. 

4. Select the pull quote frame and apply the fourth Text Wrap option, to Jump the 
object, and not allow the text to wrap on the sides of the quote.  

5. Select the anchored quote and drag up or down to adjust the location.

OR Same as above steps 1. - 3

6. Put your cursor in the paragraph return that holds the quote. Add quite a bit (~1”)
of Space Before and Align Center.

7. Make a Paragraph Style for the paragraph return that holds the pull quote. This 
way, you can add more space above or below, and align left, center or right. (use 
this method if all the quotes or graphics will be similar in height, and you’ll be 
placing quite a few of them.

8. Apply the Paragraph Style to the return that holds the quote. 

FLEIGGER, Mia
Alex, Nathaniel

354 Arlington Drive
Hanover Park, IL 60133
312/223-9866
saf.fleig@gmail.com
asfsewr@gmail.com

FREDRICK, Darin
354 Patricia Lane
Bartlett, IL 60123
312/229-0724

Cuptus por si sam re pelestrum 
quibusd aeritis expellatio. Lupta 
quae consequi quatum aut per-
rovid quaesequam volorum restini 
hicidit, consequo omni.

arisitis ea volorrovidio eic tempor-
estrum essim ditiorum ne volessit 
de di intemquist, sit evel eatempo 
saerum num aut fugit occum que 
de nos ad 

qui ommolo dolut volorit, ni untiis 
sequis ipsam et pere ide et.d quae-
sequam volorum restini hicidit, 
consequo omnis arisitis 

Anchoring a Graphic  
keeps it with the text

ea volorrovidio eic temporestrum 
essim ditiorum ne volessit de di in
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Why won’t my Text Wrap around my graphic???
Text will wrap around an anchored object in any line BELOW the line into which the object is anchored.  
If you want a graphic free to be moved and positioned anywhere, and the first line of the paragraph 
text to wrap, then you need a little trick. 

Setup 

1. Create a text frame and fill with text (Type > Fill with Placeholder Text)

2. Create a frame, fill and stroke with a pink color. This is the frame we’ll anchor into the text.

3. Click and drag the little blue square of the pink frame into the beginning of the paragraph. 

4. Apply Text wrap (with .125” offset) to the pink frame. Move frame around and notice that the text 
BELOW will honor the wrap, but the line it’s anchored into nor the lines above will wrap. 

Trick

1. Edit > Story Editor. Locate the camera icon (the anchored object) and drag over it to select. 

2. Edit > Cut. Hit Enter or Return to move the paragraph down, and put your cursor in the return that 
is above the paragraph. Edit > Paste. Your anchored graphic is now in the paragraph above, and 
the text wrap will honor for all lines of the paragraph. 

3. Now we need to make the paragraph above “be” there, but not be noticeable. 

4. Highlight the paragraph which holds the Anchor. Change the Type size = .1” and Leading = .1” (or 
the smallest measurement in mm, cm, picas etc). Make sure there is no space after or before this 
paragraph. 

5. Create a new Paragraph style, called Paragraph for Anchor. Make sure it’s applied to this 
paragraph. 

6. Now, every time you need a graphic anchored in your first line of a paragraph, make a return 
before the paragraph, Anchor the graphic into the empty paragraph and apply the Paragraph for 
Anchor style. 

7. Another cool tip - Edit the Paragraph for Anchor Paragraph Style, choose Keep Options from the 
list on the left, choose Keep with Next “1” paragraph. This way, it will always stick with the para-

graph below. (see dialog box illustration to the right)

The Pink frame is 
anchored to the 
beginning of the 
paragraph, (see the 
dotted line and the 
Y symbol).  The text 
on the first line isn’t 
moving to honor 
the text wrap, yet 
the text in the lines 
BELOW where it’s 
anchored will honor 
the text wrap.

Open Edit > Story Editor (left) to be able to select the anchor. 
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End of story icon
1. Place and size the end of story graphic to fit the space. 

2. Shift drag the small graphic to the very end of the story, after the period. 

3. Using the Selection Tool, drag the icon up or down, or use the up and down arrows on your 
keyboard. 

4. Place your cursor between the period and the anchored object, type [Shift+Tab] to put in a Right 
Indent or  “Flexible” Tab. This will force the anchored object to the right of the text frame.  
(Type > Insert Special Character > Other > Right Indent Tab)

5. When you need this end of story character somewhere else, using the type tool, drag to select 
both the shift+tab and the Inline Anchored graphic, Edit > Copy, then Edit > Paste at the end of 
another story.

6. To use a CC Library Select the Shift+Tab and the Inline Anchored graphic, make a new or select 
an existing Library. Click the “+” icon at the bottom of the Libraries panel, and add only the text 
to the library. When you need the end of story character, place your cursor at the end of another 
story, in a CC Library, find the Text section, right click and choose Place Inline.

7. Use this trick to quickly place your logo and the flexible tab as text within a story.

End of story icon
Tecaerio quat utem. Itateniet exero imolorit, 
volorem voluptati beria vendae offic tore 
nimus eaqui torerferum velessi dunt dolupid 
erciis non coresti orerunti dolorer erspeli 
berum, sinci core con entiscienis dolenim  
totatem enda consed qui dolorendipsa et vel 
lendit, se quatur? 

End of story icon
Tecaerio quat utem. Itateniet exero imolo-
rit, voloremiscienis dolenim  totatem enda 
consed qui dolorendipsa et vel lendit, se 
quatur? 

 Icon or logo within a story
Tecaerio quat utem. Itateniet exero imolorit, 
volorem voluptati  ACME

DOG TRAINING
  beria vendae offic 

tore nimus eaqui torerferum  velessi dunt 
dolupid erciis non coresti orerunti dolorer 
erspeli berum, sinci core con entiscienis dole-
nim  totatem enda consed qui dolorendipsa 
et vellendit, se quatur? 

This space is flexible  
from using a Shift+Tab
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Anchored Graphics in Tables

To place an icon or logo into a Table Cell
1. Place multiple icons on the page. Use Gridify to make sure they are all the same size.

2. Select an icon. 

3. Hold the Shift key and drag the little blue Anchor Square into the table cell. Each cell has a “#” 
indicating the end of a story in the text cell.

4. Switch to the Type tool and select cell or cells (hit escape key to select a single cell)

5. Center the text both vertically and horizontally 
in the table cell. 

Another way to place a graphic into a table cell:
This is useful if you have some text already in the cell.

1. With the Selection Tool, select an icon, Edit > Copy. Make sure that your photo, icon or logo is 
small in size. If it’s too large, it will not fit in the cell and force the text in the cell to be overset.

2. Switch to the Type tool, put cursor in a table cell, at the desired location, choose Edit > Paste. 

To place a photo into a cell
1. Choose the Selection Tool. Click on the pasteboard to have nothing selected. 

Choose File > Place. 

2. Select a few photos (hold Shift or CTRL/Command to select multiple photos). Click OK

3. Click with the loaded cursor in a cell. 

4. The photo will automatically fit in the cell. Click on another cell to place next photo. 

Trick to fit a long word into a table cell or table header row
If you must fit one long word into a table header or cell in a column that is very thin, you 
can anchor it. Make a new text frame, type the long word or phrase, then anchor the text 

frame into the cell.

Pro Business

Style ✘

Grace ✔

Charisma

IN  
STOCK

PAGE 
#

01108 In Stock 1

01102 In Stock 4

01702 Custom 
Order 14

00501 In Stock 42

 MERCHANDISING®

ITEM #
IN  

STOCK
PAGE 

#

0502 In Stock 3

2344 Custom 
Order 55

0111 In Stock 14

 MERCHANDISING®

ITEM #
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Anchor an object to a specific spot on a frame
Do you want to jazz up your organizational charts from a simple line or arrow pointing to the next 
frame? We’re going to make a little circle shape and ANCHOR it to the top, bottom, right or left of the 
frame. You CAN apply a little circle, arrow or triangle to the start or end of a line/arrow using the stroke 
panel, but what if you want different colors or sizes for the arrow than the line itself? Here is a trick.

1. Make a frame, fill with a solid color and type in a Name and Title (create two paragraph styles). 

2. Create a small circle or other shape, and fill with a different color, and stroke with paper (white). 

3. Drag the little blue anchoring square to the beginning of the Name, to anchor the shape into 
the text frame. 

4. Choose Object > Anchored Object > Options. Choose the Center Reference Point of the 
Anchored Object (indicating the center of the circle). 

5. Anchored Position Make sure both X Relative To: and Y Relative To: are set to Text Frame. X 
Offset = 0 and Y Offset = 0. Select the top middle Reference Point. (See the screen shot for the 
settings). This will make the center of the circle (the Anchored Object) sit in the top middle of 
the frame into which it is anchored. Create an Object Style with the shape selected. 

6. Now, with the type tool, drag and select the “¥” hidden character that is holding onto the 
anchored object (should be in front of the name, where you dropped the Anchored Object), 
open your CC Library panel, click the “+” at the bottom, and choose Text. Rename the library 
entry to Circle at Top. 

7. To insert this shape and anchor it to the top middle of another frame, no matter the size, place 
the cursor at the beginning of the Name, right click on the CC Library entry you created and 
choose Place Inline. 

8. The circle will appear perfectly centered at the top middle of the frame! 

9. Make More! - Change the Anchored Object Options for the bottom, left, right sides and even the 
corners, and save them as an Object Style, then an additional CC Library entry to easily insert 
more.

10. Now you can move around the frames, resize them, and the shapes will stick to the edges or 
corners, where ever they are anchored. This is a great trick for infographics, call out 
boxes and more!

Laurie Ruhlin
InDesign

The circle is selected, reference 
point is the center, Anchored 
Position is the top center of the 
text frame it’s anchored in. 
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HEADING
Omnis simaioressi que odipsape mo te sae nis-
qui in expellent aut lanimusandis dolorectium 
es untis aut volorenim core

 STEP ONE
SUBHEADING
doluptiatiis esed quiatum earum repere sitatur 
re, eatur, ut rehente possunt facil iunditatam 
lam eritatur? Quis abo. Nequis eatem cum 
earum

STEP TWO
SUBHEADING 2
sitatur re, eatur, ut rehente possunt facil iundi-
tatam lam eritatur? 

STEP THREE
SUBHEADING 3
sitatur re, eatur, ut rehente possunt facil iundi-
tatam lam eritatu f

Triangle has a 
“Ribbon Shadow” 
Obj. Style applied 
which controls the 
width, height, color 
and placement 
relative to the text 
frame into which 
it’s anchored.

Step One is a Paragraph 
style, text is size 18, Caps 
and has Paragraph shad-
ing to hang off the frame

Triangle is 
anchored at 
beginning of 
Step One word

Anchored Ribbon
When I design a document, I like to make it as visually pleasing and as “cool” as possible, but most 
importantly, EASY to apply the formatting and EASY to make changes. This ribbon with Step 1, 2 etc., is 
text formatted with a Paragraph Style. The triangle shadow is anchored into the text, and it sits per-
fectly under the shaded line. It is anchored into the text paragraph so it travels when text is added or 
deleted.

1. Place text, format and make paragraph styles for the 
Heading, Subheading, Body Text. 

2. Type STEP ONE. Format with All Caps, text size and 
some space before and after. Add Paragraph Shad-
ing (see dialog)- Blue, 50% tint, and extend it left and 
right, off the frame edges. 

3. Draw a triangle. Fill with Blue 80% tint. Anchor tri-
angle to the beginning of the STEP ONE text, by drag-
ging the triangle’s Anchor Square. 

4. With the Triangle selected, Object > Anchored Object > Options. Choose the top right corner of 
the Anchored Object (triangle) and the left edge of the Anchored Position (frame).  
Change X relative To: Text Frame. X Offset will be 0,  
Change Y relative To: Line (baseline) Y Offset will be 0.125 in. (or so, play with exact numbers)   
This positions the triangle to the bottom of the shad-
ing and on the left of the text frame exactly. Make 
an Object Style for the Ribbon Shadow Triangle to 
apply the color, tint and size/position and anchored 
potition. 

5. Repeat: Type STEP TWO, apply the paragraph style, 
then copy the triangle and paste it in front of the 
words, making sure to apply the Object Style.

Left of the text 
frame

Top right of the Rib-
bon triangle Shadow
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If you liked this webinar, 
you’ll love...

REGISTER TODAY
CreativeProWeek.com

5 days. 70+ sessions. Zero regrets.
June 2–6, 2025

Phoenix, AZ

https://creativeproweek.com


“Your speakers know what 
they’re talking about, love 
what they do, and are 
all about sharing their 
knowledge… I can’t wait for 
next year!”

—�Jay Newmarch 
Owner, CRE8 Design LLC

“I learned more in the first two 
days than in the past 8 years… 
this was the single greatest 
learning event I have ever 
been a part of.”

—�Sean Lee 
Wide Format Graphic 
Designer, The H&H Group

CreativePro Week is the world’s best how-to conference for 
creative professionals who design, create, or edit in InDesign, 
Photoshop, Illustrator, Acrobat, and PowerPoint.

No matter your skill level, you’ll learn techniques and best 
practices you can start using immediately to improve your 
productivity.

Our industry is changing faster than ever, and new products 
and techniques emerge every day. CreativePro Week helps 
keep you ahead of the curve and ensures you continue your 
professional development. 

Featuring over 35 expert speakers and 70 sessions, CreativePro 
Week offers five days of in-depth training and inspiration, all 
in one place. If you can sign up for only one event in 2025, 
it should be CreativePro Week.

CreativePro Week 2025 
MASTER THE TOOLS OF DESIGN. FIVE DAYS. ZERO REGRETS.



The Essential Resource for Design Professionals

If you are a graphic designer, publisher, or 
production artist, CreativePro Network is here 
to support you with resources, knowledge, and a 
community to help you master the tools and raise 
your skill set to the next level.

Since 1999, CreativePro Network (CPN) has 
provided essential how-to training for users of 
Adobe InDesign, Photoshop, Illustrator, Acrobat, 
Microsoft PowerPoint, and more.

The industry is changing faster than ever, and 
new products and techniques emerge every 
day. CreativePro Network helps you stay current 
and ensures you continue your professional 
development.

CreativePro.com is the cornerstone of CreativePro 
Network’s wide platform of information 
resources with a collected annual reach of over 5 
million readers.

Our philosophy — Learn, Create, Share — drives us 
to provide year-round, full-circle learning to support 
your creativity and career.

Our full range of products include:

	X CreativePro Membership – Grow and stay current 
with member‑only discounts, downloadable 
templates and scripts, weekly how-to newsletters, 
access to our forums, and more.

	X CreativePro Magazine – Monthly PDF magazine 
with in-depth features, reviews, and tutorials you 
need to master the tools of design.

	X CreativePro Events – Learn mind-blowing tips, 
techniques, and best practices from the industry’s 
top experts.

	X CreativePro Week – Our annual event covering 
InDesign, Photoshop, Illustrator, Acrobat, Power-
Point, and more.

	X CreativePro Books – Essential books and ebooks 
for creative professionals.

	X And more… Thousands of tips and tutorial articles, 
hundreds of podcasts, interactive online courses, 
instructional YouTube channels, and thriving 
community groups on Facebook and LinkedIn.

https://creativepro.com/?utm_medium=Ad&utm_source=EventHandout
https://creativepro.com/sp/become-a-member/?utm_campaign=Membership&utm_medium=Ad&utm_source=EventHandout
https://creativepro.com/issues/?utm_campaign=Magazine&utm_medium=Ad&utm_source=EventHandout
https://creativepro.com/events/?utm_campaign=CPEvents&utm_medium=Ad&utm_source=EventHandout
https://creativeproweek.com/?utm_campaign=CPW25&utm_medium=Ad&utm_source=EventHandout
https://creativepro.com/product-category/book/?utm_campaign=Books&utm_medium=Ad&utm_source=EventHandout


Become a Member

Sign up now at 
CreativePro.com/become-a-member

Get year-round access to resources that will  
keep you current and strengthen your skills 

For just $6.50/month (billed annually), you’ll get access to valuable benefits, including:

 CreativePro Magazine
 Downloadable Resources

 How-To Articles
 Exclusive Discounts

�  Top Tips Ebooks
 Members-Only Forums

https://creativepro.com/sp/become-a-member/?utm_campaign=Membership&utm_medium=ad&utm_source=WebinarHandout


Learn more about our events and explore the full calendar at 
CreativePro.com/events

Upcoming Events

https://creativepro.com/events/?utm_campaign=CPEvents&utm_medium=ad&utm_source=WebinarHandout
https://creativepro.com/presentation-design-conference-2025/?utm_campaign=PDC25&utm_medium=ad&utm_source=WebinarHandout
https://creativepro.com/design-accessibility-summit-2025/?utm_campaign=Da11y25&utm_medium=ad&utm_source=WebinarHandout
https://creativeproweek.com/?utm_campaign=CPW25&utm_medium=ad&utm_source=WebinarHandout
https://creativepro.com/design-ai-summit-2025/?utm_campaign=DAIS25&utm_medium=ad&utm_source=WebinarHandout
https://creativepro.com/design-marketing-summit-2025/?utm_campaign=DMS25&utm_medium=ad&utm_source=WebinarHandout
https://creativepro.com/indesign-conference-2025/?utm_campaign=IDC25&utm_medium=ad&utm_source=WebinarHandout

